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An Overview of WINKS

WINKS is a statistical data analysis program. It is the Windows version of the DOS 
KWIKSTAT program and was designed by professional statistical consultants and 
researchers to allow you to quickly and easily use the most commonly needed statistical 
data analysis procedures and graphs.

Managers and researchers must make decisions. Data analysis is a tool that allows you to 
make informed decisions. Today's business graduates, scientists and researchers have 
been trained in the use of data analysis.  However, the mainframe statistics programs they
used in college are often not available on the job, or are difficult to use and understand. 
These programs often require programming expertise to use and a statistical expert to 
interpret. WINKS was created to provide access to data analysis in an easy to understand 
Windows format. It was designed with the decision-maker and researcher in mind. 

Why Use WINKS?

The designers of WINKS are interested in helping the user: 

1. select the appropriate data analysis procedure to use,

2. enter data or use data already in popular formats such as dBASE, 1-2-3 or ASCII,

3. provide a complete analysis in one pass so the user does not have to run multiple 
programs to perform a single analysis, and

4. provide interpretation of the results to assist the user in making decisions based on the 
outcome of the analysis.

These objectives have been addressed by the program and supporting documentation:

1. WINKS provides a Help procedure that guides you to the most appropriate analysis for
your data. The manual provides a decision tree to help guide you to  an appropriate 
analysis procedure. 

2. WINKS provides an easy to use data entry system as well as the ability to 
automatically read and write industry standard DBF (dBASE III and IV) files. In 
addition, WINKS can also import data directly from 1-2-3 and ASCII files, and paste data
directly into the WINKS data editor from any Windows spreadsheet program.
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3. WINKS is designed to anticipate your analysis needs and lead you to a conclusion, 
unlike many statistical programs that make you run each part of an analysis separately. 
For example, in the case of Analysis of Variance procedures, multiple comparisons are 
automatically performed to show you where specific pair-wise differences lie.

4. WINKS provides interpretation of analysis both on screen and in the printout. 
Interpretations may be in the form of warnings when common assumptions are not met 
and in suggestions about how a particular outcome could be interpreted. For most tests, 
an explicit hypothesis is stated to help you understand the exact intention of the analysis.

The following sections contain an overview of how to use the WINKS manual and 
program. 

Installation

Place the WINKS distribution disk (disk 1 if there is more than 1 disk) in the A: (or B:) 
drive. From the Windows File menu choose "Run " (or choose "Run" from the Start 
menu in Windows 95)  Enter or select the command 

A:\SETUP.EXE     or (B:\SETUP.EXE)

Follow the installation instructions on the screen. When you begin WINKS for the first 
time, a dialog box will appear allowing you to choose some program options. Select 
options you want to change, or leave the default options in place and choose Ok. You can 
change these options at any time by choosing "Change Setup Options" from the Help 
menu.

WINKS Compatibility with KWIKSTAT

WINKS data files are compatible with all versions of KWIKSTAT. If a file is created in 
WINKS, it can be used in KWIKSTAT, and vice versa. The only difference is that 
formulas entered in the WINKS data editor will not be used in the KWIKSTAT data 
editor.  

Definitions

The following definitions discuss some of the terms that will be used in this chapter and 
throughout the manual. 

DATABASE - a collection of data records defined by common fields or information (such 
as survey results). A record (row) represents one complete entry in a database file. The 
field (or columns)  represent individual elements (or variables) within a record (such as 
AGE, HEIGHT, etc.). WINKS uses the .dbf dBASE file structure for defining computer 
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database files. 

FIELD - a unique element (or variable) of a database record. A field may contain 
information that is numeric, character, date or logical. A field or variable is the name 
given a set of values or character descriptions (such as a grouping label for an ANOVA 
analysis.)
GROUP - a specific field intended to be used to classify data within the database (such as
gender.) For example, a group field could be SEX, and contain the information F or M. If 
the SEX grouping field in the record contained an F, the data would be about a female. If 
the SEX grouping field contained an M, the data would be about a male. 

LABEL - a database field containing information that will be used as labels on a plot. 

STATISTICS - calculated values that summarize a collection of numbers. For example, the
arithmetic average (also called a mean) is a statistic. 

VARIABLE - same as Field. See Field above. 

Using the WINKS Menus

WINKS menus are similar to any Windows program, and are similar to the KWIKSTAT 
menu. In the documentation main menu items are shown in italics, such as File. Options 
on main menus appear in quotes, such as "New Database" Here is a brief description of 
each menu: 

Using the File Menu

Before you can create a graph or calculate statistics, you must create a database and enter 
data. The options on the File menu are:

o New Database - You must usually create a new database and enter data before doing an 
analysis or creating a  graph. The program creates and reads dBase (.DBF) type file 
format  databases. 

o Open Database - Open an existing database. A  database must be opened so the program
will know where the data is  located. 

o Delete Database - Deletes a database file from your disk.

o  Utilities - Imports information, creates reports, sorts database or outputs data.

o  Journal - Allows you to print, clear or edit the current contents of your Journal file.
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o  Printer Setup - Allows you to choose which printer to use.

o  Exit - Ends the program.

Using the Edit Menu

The Edit menu contains options that allow you to enter new data into a database, or edit 
data currently in a database.  

Using the Analyze Menu

The WINKS Analyze menu allows you to choose which analysis module to run. The 
menu items on the Analyze menu are:

o  Descriptive Statistics

o  Graphs/Charts

o  t-tests and ANOVA

o  Non-parametric Comparisons

o  Regression & Correlation

o  Crosstabs, Frequencies, Chi Square

o  Life Tables, Survival Analysis

o  Advanced ANOVA (Professional edition)

o  Advanced Regression (Professional edition)

o  Multiple Comparisons (Professional edition)

o  Time Series Analysis (Professional edition)

o  Quality Control Charts (Professional edition)

o  Pareto Charts (Professional edition)

Using the Windows Menu

The Windows menu is used to select which menu will be displayed, when more than one 
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menu is defined. An example of displaying two windows side by side is given in the 
tutorial in this chapter.
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Using the Help Menu

The WINKS Help system contains items to help you operate the program. These include:

o  Help Contents - Contains general program help information.

o  Print order form - Prints order form for WINKS. 

o  View/Print Docs -View or print supplemental documentation

o  Change Setup Options - Default directory, hints, etc.

o  About WINKS - Program copyright information

TUTORIALS
                   
These short tutorials will give you a feeling for how to use WINKS. They is not intended 
to be thorough, but simply to lead you through some common procedures. Begin WINKS
by double clicking on the WINKS icon in Windows. The initial WINKS screen appears. 
Notice the parts of the WINKS screen. 

At the top are the menu options (the menu bar), File, Edit, Analyze, Window, and Help. 
Below the menu bar is an icon tool bar (unless you turned it off in the program options 
setup.) These icons are shortcuts to commonly used procedures. Make note of the 
"Repeat" icon (shows several repeating pages) and the "Journal" Icon (notebook and 
pencil.) The "Repeat" icon allows you to repeat the last procedure you performed.  The 
"Journal" option allows you to collect your analysis output from any WINKS procedure 
into a single file that you can use later to print or import into your word processor. Menu 
bar  icons are:

ICON MENU ITEMS ON THE ICON BAR

o  File Cabinet Icon - Open a file

o  Spreadsheet Icon - Edit data

o  Xbar Icon - Calculate statistics and display a histogram

o  Scatterplot Icon - Display a scatterplot graph

o  Charts Icon - Displays the First Impression Chart Gallery

o  Repeat Procedure Icon - Repeat the last procedure
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o  Report Icon - Display or print a simple data report

o  Journal Icon - display the contents of the journal.

o  Help Icon - Display Help

o  Exit Icon - Exit the program

EXAMPLE 1 - Descriptive Statistics

This example shows you how to open an existing database, display descriptive statistics 
on a single variable, and display a histogram. Follow these steps:

Step 1:  The Detailed Statistics analysis is represented on the icon tool bar by the ( X-bar)
icon. Click on the X-bar icon. A dialog box will appear asking you if you want to CReate 
a database, Open a database, or Cancel the analysis. Click on the Open a database button. 
(You could also choose File/Open or click on the file cabinet icon to open a database 
file). The Open dialog box will appear. Select the file named EXAMPLE.DBF. (You may 
have to scroll the file list to see the EXAMPLE.DBF file name. Either double click on 
EXAMPLE.DBF, or click on example, then click on OK.) Notice at the bottom of the 
screen, a message tells you that the EXAMPLE.DBF database is opened.

Step 2: Once you have opened the EXAMPLE.DBF database, a dialog box will appear 
where you can choose a field name. Click on AGE, then on OK.

Step 3: - After a few seconds, a screen appears containing descriptive statistics from the 
data in the AGE field. Scroll this window to view information off the screen. The viewer 
that contains the text output for an analysis is called the "View Results" window. Later, 
we'll also see a "Graphics Viewer". The View Results Window (or "Viewer" for short) 
will appear following calculations for most analyses, allowing you to see the textual 
results of your analysis. You should become familiar with the options on this viewer. 
View Results Window  MENU OPTIONS:

Exit - Exit the window. NOTE: This is different than the EXIT Arrow. The Exit button 
closes the View Results Window only. The Exit Arrow exits the program.

Print - Prints the contents of the View Results Window to a printer.

Clipbd - Places the contents of the viewer into the Windows clipboard, so you can paste it
into another application such as a word processor.

Save - Save the contents of the View Results Window to a file. 
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Journal - Copy the contents of the Viewer into the Journal.

Graph - Display a graph appropriate to this analysis.

Step 4: Click the "Graph" button to display the histogram associated with this data. A 
screen will appear showing a histogram of the AGE data. Click on the "Bell" button to 
add a bell curve (normal curve) to the graph. The menu options on the Graph viewer are:

GRAPHICS VIEWER MENU OPTIONS

Exit - Exit the graph window. Note: Notice the difference between the EXIT Button in the
Graph Viewer and the EXIT Arrow, which is the program exit.

Print - Print the graph to the printer.

Clipbd - Capture the graph into the Windows Clipboard, so you can paste it into another 
application such as a word processor.

Save - Save the graphic as a .BMP file.

+ (plus) or -(minus) - Change the size of the class interval for the histogram. This usually 
changes the number of bars on the plot.

Bell - Displays a bell-shaped curve over your data. 

Counts - Displays counts for each bar on the histogram.

Distribution - Cycles through three options: No distribution displayed, Cumulative 
Distribution, and Cumulative Normal Distribution Displayed.

Title - Allows you to specify a title for the graph.
Step 5: From the Window menu at the top of the screen, select the "Tile" option. This 
causes the two output windows (text and graphic) to be displayed side by side. Notice 
that the graph is resized to fit into the smaller window. The View Results Window, also 
resized, contains both vertical and horizontal scroll bars, allowing you to view any part of
the output report. You can still choose the button options in either the graph or report 
viewer. You can exit either viewer by clicking on the "Exit" option in the viewer window. 
When you begin another analysis, the contents of the current viewers are erased to make 
room for the information from the new analysis.

Step 6: This ends the first example.
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EXAMPLE 2 - Creating a Database

This example shows you how to create a database, then use the information in the 
database to perform an analysis and display a graph. 

Suppose you are testing the effectiveness of four kinds of hog feed. You randomly assign 
15 hogs to 4 groups and feed each group one of the feeds. You want to use a one-way 
analysis of variance (independent group) to analyze this data. This example shows how 
you would create an appropriate database, enter the data, and perform the analysis.

Step 1: From the File menu, choose "New Database." You are asked to enter the name for
your new database. Enter HOG (Or any DOS compatible filename.) Choose OK. 
(Note:This database is the same as the HOGDATA.DBF file on your disk.)

Step 2: - A dialog box will appear listing database types. Click on the down arrow at the 
right of the text field to display the options. 

To create a database for this analysis, choose the option "Independent Group t-test or 
ANOVA" from the list and choose OK.

Step 3: An empty spreadsheet will appear containing the two fields: GROUP and OBS. 
The GROUP field will contain a code for feed type. For this example we'll use 1,2,3, and 
4. The OBS field will contain the variable you observed. In this case it is weight gain. 
Enter the following data into the spreadsheet. Enter one row at a time. When you enter a 
complete row, and press Enter on the OBS field cell, a new row will be added to the 
spreadsheet.

The HOG database values are:
       
       GROUP  OBS (WEIGHT)
       1          60.8
       1          67.0
       1          54.6
       1          61.7
       2          78.7
       2          77.7
       2          76.3
       2          79.8
       3          92.6
       3          84.1
       3          90.5
       4          86.9
       4          82.2
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       4          83.7
       4          90.3
       
Step 4: When you have finished entering the data, select the "Exit Edit" option from the 
File menu. You will be asked if you want to save the data before exiting. Answer "Yes."

Step 5:  Click on the Analyze menu and select the "test and ANOVA" option. A sub menu 
will appear. From the sub-menu, choose the "Independent Group (t-test/ANOVA) option.

Step 6: Choose what fields to use. A dialog box appears allowing you to select which 
fields to use for this analysis. Select the GROUP field, and click on the GROUP button. 
Then select the OBS field and click on the ADD button. Click OK to continue.

Step 7: After a few moments of calculation, the View Results Window will appear 
containing the output information for this analysis. See Example 1 for more information 
on the View Results Window. Use the scroll bars to view output analysis text that is off-
screen. Print the output by clicking on the "Print" button.

Note: If you only want to print or save a portion of the output, first highlight the text by 
clicking and holding the mouse button, and dragging the mouse to highlight the area, then
choose "Print" or "Save."

Step 8: Click on the "Graph" button on the View Results Window to view the graph 
associated with this analysis. The default graph, shows a box and whiskers plot 
comparison.

Step 9: From the group comparison plot, you can select from among a variety of display 
options. Click on the "Options" button to display the options menu for the graph. 

Step 10: For this example, check the following options (and uncheck all other options) on
Graph Options dialog box:

o  Display Means
o  Error Bar (+/- St. Error of the Mean)
o  Connect Means
o  Bar Graph of Means

The graph will be displayed. Print the graph by clicking on the "Print" button.

Step 11: This ends the examples. Exit WINKS by clicking on the Exit Arrow on the 
WINKS icon bar or by choosing Exit from the File menu.
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More Examples in Help

For more examples of how to use WINKS, refer to the Help Contents in WINKS.

Please Register

This is an unregistered copy of WINKS. For continued use, you must purchase a licensed 
copy. Print the file WORDER.TXT on disk, or from the Help menu, select "Supplemental
Documents" and print the order form from that menu.

Or, call TexaSoft at 800-955-TEXAS or 214-291-2115 or Fax:214-291-3400. Our e-mail 
address is 70721.3145@compuserve.com and our Web site is 

http://www.texasoft.com/homepage.
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